Robostix toolchain

From Gumstix User Wiki

Jump to: navigation, search

This page describes setting up the AVR toolchain, needed to build code for the robostix and roboaudiostix boards.

Install compiler

When things work, you can do the following under ubuntu:

sudo apt-get install gcc-avr avr-libc gawk

However, some versions of avr-libc will give you compile errors when trying to build the i2c bootloader. (the error will mention __eerd_block). Ubuntu 9.04 installs a version of avr-libc with this problem. See below for details on manually installing a newer runtime library.

Manually install runtime library

The following steps can be used to install (or replace) the avr runtime library (avr-libc). Ubuntu-9.04 installs version 1.6.2, which has some issues.

wget http://mirror.csclub.uwaterloo.ca/nongnu/avr-libc/avr-libc-1.6.7.tar.bz2
tar xjf avr-libc-1.6.7.tar.bz2
cd avr-libc-1.6.7/
./configure --build=`./config.guess` --host=avr --prefix=/usr/lib
make
sudo make install
Personal tools